No tasks retrieved from ClickUp List (and Usability Issues)

Description of the issue:

I tried to get all tasks from a ClickUp list, which worked for the first time, but now it’s no longer pulling up any tasks, saying the list is empty, even though I can clearly still see tasks there.

Additionally, sometimes it’s bringing in tasks that were removed from the list, is it possible that it’s caching the results somehow?

Error message (if applicable):

No error, but I’m getting this response:

The command worked, but no tasks were found.

Steps to reproduce this issue:

Please provide a detailed account of the steps taken to encounter the issue. Where did you start? What actions did you perform? Where did you encounter the error?

I started with the template automation for ‘Save ClickUp tasks to Notion’, which worked for the first time, and pulled in the tasks, but I then did some clean up in ClickUp, and re-attempted the import, but found that it’s pulling older data. I restarted the browser, and now it’s pulling in nothing…

Bardeen version: 2.26.1
Link to Playbook or Autobook (if applicable):
:movie_camera:Video recording or screenshots (optional, but recommended):

Hello there!

I tried to setup another automation that does not requre a premium plan. However, when creating an action “create a Clickup task” - I can not select the list where the task should be created. In fact, it does not shows neither suggestions when typing, nor the list when the list name is typed in. I have not previously encountered this issue when working on the last automation.

I have it connected to Bardeen, tried re-installing the app and restarting the computer. However, no luck.

Looking forward to any assitance or suggestions.

Hey @Marko and @amro.khir! Thank you so much for sharing such a detailed report on the issue you’re facing with ClickUp for your automation.

We’ve reported this and fully understand how urgent and blocking it is for you.

In the meantime, you can try deleting the integration and adding it back again to see if that helps. Keep us updated on how it goes, and we’ll be right here to assist you further.

Hey @ivan!

Unfortunately, deleting and reinstalling the integration didn’t help. Could you provide any timeframes when this can be fixed? It would really help me and my team a lot.

Thank you!

Thanks for running that check! We’ll try to prioritize this since it could be blocking the integration.

No clear timeline unfortunately :frowning:

We’re so sorry for the inconvinience and hope to get this fixed soon!

Hi @ivan!

Hope you are feeling better. I would like to follow-up on the bugs about ClickUp. Is there any way I can help speed this process up? Bardeen is a crucial integration for our team, we will be glad to use it again.

Best,
Marko

I connected my clickup workspace, and it’s not seeing any of my lists when I try to create an automation. Any ideas on how to troubleshoot this ?

Hi @marylene - sometimes it takes Bardeen a minute or two to register the data after connecting to an app. I would try reinstalling the extension and see if that does the trick. I hope this helps!

I’ve just reinstalled it as per your suggestion, but still no success, I get an error message for API not being able to connect with Clickup, which I sent to Bardeen. I’m wasting all my trial days and so much time just to connect my apps, it’s annoying, especially for an app that is suppose to help save time lol

I’m sorry for your experience. It is frustrating. Bardeen will likely provide you with more trial days though!

When trying to connect, make sure you’re using the Chrome browser. Bardeen works best on Chrome. I hope this helps!

I’m still unable to use Bardeen for my list… It’s bizarre because it does see my clickup team members and myself so clickup is truly connected, but any automation that requires me to choose a list shows no results. I really wanted to use this tool, but it’s so frustrating, I don’t think I’ll even bother finishing the trial and certainly not paying for a pro account. No support team has reached out to me since I reported the bug

Hi @marylene - I’m tagging @ivan for further assistance and addressing your frustrations. I’m confident you’re in good hands and everything will be sorted soon!

I don’t have Clickup so I’m unable to test on my end for you at this time.

Hey @marylene

Sorry about the delay, should’ve spotted this beforehand.

When sharing bugs and issues, I recommend you to use the :lady_beetle: Report an issue channel. Here’s a small guide.

Your issue seems to be the same as this bug report:

I’ve raised awareness of this to our team and hope it can be approached on the next releases. It’s on our engineer’s pipeline for fixing!

I’ll merge the 2 posts.

Hey folks,

Wanted to say hi and personally apologize about this. We are in the process of revamping a some of our integrations and fixing a bunch of issues. ClickUp is one of the next ones in line. We will definitely get to it and will have all the issues fixed soon. Please stay tuned and thank you very much for your patience :pray:.

Cheers,
Artem.

Hello @Artem_from_Bardeen , @ivan !

Hope you are doing great. I just wanted to follow up on Artem’s last message regarding the ClickUp issues. Is there any approximate time frame when the update can be expected?

Looking forward to hearing from you,
Marko

Hi @Marko

We have run updates on our Clickup integration and it’s on the review process.

You can test updating Bardeen to the latest version on the next week.

CC: @govert

Hi @ivan

Thank you for the heads up. Will be looking forward to testing everything out in the update. Really appreciate the feedback and have a great rest of the day!

1 Like

Greetings Ivan, @Artem_from_Bardeen !

I am reaching out once again regarding the issue with Clickup

I have tried every method possible to find a way to fix the bug by reinstalling Bardeen, reconnecting Clickup. And also tried to purchase a premium subscription since I supposed that the first time I was connecting Bardeen to Clickup it was free, therefore I assumed since that integration part is now a paid option and at first I created it when Bardeen was completely free this will work. However, no luck at all.

I am attaching a small Loom video I recorded for you to better understand the issue. As mentioned before, Bardeen is connected to the proper workspace in Clickup, the subscription has been paid and the issue is yet to be in the past.

Please take a look at the video and I will be waiting for any updates from your side as soon as possible.

Best regards,
Marko

I have the same exact issue

HI @marylene @Marko @amro.khir

We have released new updates on Clickup which are available on Bardeen’s latest version.

Are you in 2.37.1?

Please update Bardeen this way
Updating bardeen