Autobook run after I turned it on

I have some scheduled autobook, and when I edited it and save, the autobook will turn off.
The weird thing is that when I turn it on, it will run right away, which is not the time I scheduled.
Please fix this, or I’m wasting my credit every time I need to edit them!

Hi @nri.scraping

Thanks for reporting this!

Can you share more details on your use-case, maybe if you have an automation where we can try to reproduce this?

I think right now the autobooks are set to run right after you activate them.

This is helpful sometimes, when you want to test the automation, yet it also consumes credits.

You have a good point. We’ll discuss this with the team!

Hi Ivan,

I would like to share about the use case.
We are building a automation that can scrape news content everyday and sync to Notion and Google sheet,
so we scheduled autobooks everyday.

In my opinion, the “test autobook” feature should be separated from “activate autobook”.
Maybe you should consider add a “test autobook” feature so you can test scheduled autobook any time, and leave the “activate autobook” feature really just activate it.

Hi @nri.scraping,

thanks for sharing context on this, and sorry for the bad experience.
Can you elaborate on the When command that you use? It sounds like it’s " When a scheduled event occurs" with a setting of e.g. “today at 9AM” and a “repeat daily”. Is that what you are using?

Every edit of an Autobook will create a new instance, which won’t remember that something ran previously. The logic is in fact “9AM or later” – so if you create an Autobook that’s scheduled for 9AM and edit it later than 9AM, it will run immediately. If you edit it at 7AM, it won’t run immediately.

You can also adjust the schedule to say “tomorrow at 9AM” and “repeat daily”– then it will not run immediately.

We’ll look into ways of allowing dry-run of Autobooks, but for now I think adjusting the schedule when editing is your best option.

Let me know if that helps

Hi Matthias,

Thanks for the detail explaining, it does help!
Though it’s not easy to get it, but I now understand the logic behind it :smiley:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.