Help with Scraper - Failed to invoke ‘update google sheet rows in tab’

Hi, I hope all is well!

I’ve been having two scrapers lately, one for a LinkedIn person URL and one for a LinkedIn Company URL.

They seemed to be working relativley well and I built a workflow for extracting data from one column, scraping the link, and then inputting the scrapped content into another column. However, now it seems to have stopped to work completley. It keeps on returning the following.

Failed to invoke ‘update google sheet rows in tab’."
Skärmavbild 2023-07-13 kl. 09.22.46

I have deleted your post in Report an Issue. Let make sure this is not a problem with your setup first.
Have a look at this post I’ve made

Hi - it is not my set-up. I’ve tested the above many times over.

I have the same issue even after following your FAQ @Deyan_Petrov

1 Like

@Deyan_Petrov the thing is that you can have a functioning set-up, where you practically follow your instructions above, but then after some time the automation breaks down. It seems like a bug.

Hey @william and @idealabs, can you share the automations links that are running into this issue?

Also if you have any links for us to reproduce!

Might be a :lady_beetle: Report an issue, but want to double check!

Hi @ivan Here’s two variation that work on and off, meaning I try them and they work temporarily. As a paying subscriber much in need of these two automations for my work, I would love to get it sorted our rather quickly.

Automation 1 (Shared Playbook | Bardeen).

Automation 2 (

For the last section in the automation, the last part “update google sheet rows” will update by itself on the “update rows with data” and use commands or ask for manual input. Here’s how that looks like.

@ivan Same here. It didn’t work for multiple iterations, then it worked 1 time, now it’s not working again.

Same error: Failed to invoke ‘update google sheet rows in tab’.

here’s the playbook: Shared Playbook | Bardeen

@william In the Automation 1 I am not sure why are you adding 2 custom tables to update rows.
I would remove the convert to array, point the Scraper to Get Table and the Col, Point the Update rows (Find rows by value) to the same Get table from the scraper, I assume this is Person Linkedin Url. And it would work fine. If you want to share the Google Sheet with me I can fix it otherwise I do not have access to the columns to be able to select them. You can share on DM if you do not want it public.

@sorin.petrov you have selected the wrong item in Search by Col, this needs to be the name of the column inside the sheet. If you remove that and select the field and than scroll down in the suggestions you will see the names of the columns that are inside the Tab “LinkedIn Scrape Test”

Hi @Deyan_Petrov Thanks for taking a look at this, I appreciate this.

Yes, pleas take a look at booth the automations below and update it in the document, I will share it with you on DM.

Automation 1: Person LinkedIn Url Scraper (Shared Playbook | Bardeen).

Automation 2: Company LinkedIn Scraper (Shared Playbook | Bardeen).

Both of them are not working. You mentioned that one of them contains a double “2 custom tables to update rows” this is what Bardeen auto updates after a run that was malfunctioning. So if both the automation could work in the document I will share with you that would be very appreciated, it is the main value I derive from the app.

Tried it, still didn’t work unfortunately.

There’s an ongoing bug with the update google sheet rows. Our engineering team is checking this, hope to get updates soon.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.