Scraper Template sharing fails

Someone on my team shared a scraping job me (BiT Scrape Events Search Listings) which runs for him, but fails on my end.

I duplicated his task and ran it (BiT Scra… craig) but it also failed. Specifically the first step that calls the scraping template gets no results and feeds that into the second step. Eventually, I deleted the Scraping Template and re-created the exact same template and this time it worked.

I also noticed that when I had attempted to edit his scraping template which is linked to from my copy, the changes would not save. It appears that somehow I am not really able to fully access this template, despite my account being admin.

Bardeen appears to not be allowing these shared templates to fully run on someone else’s account. Bardeen should either make a FULL copy which includes a copy of the scraping template or give permissions to access the original template. Please advise…


Could you please share a link to the playbook you are trying to work with ?

Usually if the first action is getting data from somewhere, you’ll need to have acccess to that source in order for the playbook to work. When you rebuilt it, I’m assuming you remapped all the inputs to the playbook and that is why it worked.

With regards to scraper template edits not saving, this is something we fixed in our latest version. Could you please try updating your version of Bardeen to the latest version. Thanks and let me know if you’re still having issues.

Customer Support -
Explore | @bardeenai | Bardeen Community

I have opened access to the Playbook “BiT Scrape Event Listings Search - help” which is a copy of the other person’s playbook that is failing to return results. ive removed the second step to share it:

1 I have the latest version of Bardeen, but just to be sure I re-downloaded it and faced the same issues, trying to scrape from a public web page using the current page.

2 I am saying that specifically, if I have copied a team member’s playbook which includes a Scrape Template, the template fails and I cannot directly edit this Scrape Template

3 When I look at my personal Scrape Templates, I notice that no original or copy of the Scrape Template “BiT - search event listings” is directly accessible from my profile, despite having copied the parent Playbook… so the copied playbook must be pointing to other user’s Scrape Template that I cannot run nor copy nor edit

it should be run from this page: Bandsintown | Live Music, Concert Tickets, Tour Dates & Live Streams

I’ve looked through the playbook and it is likely happening because the layout of the page you are trying to scrape and the layout of the page that the scraper is designed for are not similar.

We can help you build a scraper for the link you shared , do you mind letting us know what fields you want to scrape from this page ?

Customer Support -
Explore | @bardeenai | Bardeen Community

ok i missed that with there being a different version of the page. Also, now I see that when i copy over a new Playbook, I can edit the job.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.