Scraping Euro amount to airtable truncates the digits after the dot

Hello Community,

I am trying to transfer a euro amount e.g. 99.800€ into a number field in Airtable.
The good news is that Bardeen only transfers the numbers, although the € sign is marked. The bad news is that Bardeen only transfers the numbers before the dot. However, the dot is only a thousands separator.

So the question is: How do I get the complete price of 99800 into a number field after Airtaible?

Maybe I need to prepaire the marked selectors? But I do not really understand how

DIV.list-item:first-of-type > > DIV.align-center.pricing:last-of-type > SPAN.price_buy:first-of-type > SPAN.price:first-of-type

BODY#evdb HEADER#header + MAIN DIV.jplist.content DIV.list DIV.list-item DIV.pricing.align-center SPAN.price_buy SPAN.price

*#evdb > * > *.content.jplist > *.list > *.list-item > *.data-wrapper > *.align-center.pricing > *.price_buy > *.price

BODY#evdb > MAIN > DIV.jplist > DIV.list > DIV.list-item > > DIV.pricing > SPAN.price_buy > SPAN.price

DIV:first-of-type > DIV:first-of-type > DIV:last-of-type > SPAN:first-of-type > SPAN:first-of-type


Many thank in advance!

Hi @LastSamuraj, Welcome to the Bardeen Community :slight_smile:

Good news, you don’t need to update the selectors for this use case to separate the € sign from the amount.

Try this:

  1. “Split String” action to separate the Euro Sign from the price amount:
  2. “Get rows of a table” to insert into a table for the Conditional statement next to read.
  3. “Conditional Statement” to only pull the rows where the Price column is not empty.
  4. Get rows of a table for only the rows that actually have the Price amount you’d like to input into Airtable.

Here’s the built playbook for your reference:

I hope this helps!
Thank you,

1 Like

Many thanks for your help at this late stage. I have copied your suggestion in my environment. Unfortunately, it did not help. Only the number 99 of the amount is saved in my Airtable cell. I am attaching two screenshots here. Maybe you can see if I have made a mistake?

In the meantime I have learnt to work with regex formulas and to use them. I thought maybe I would try to remove the dot and the Euro character using the regex command. But that didn’t work either.

I tried the following regex commands:


Hi @LastSamuraj

I forgot that Regex would work too. Let’s use just Regex for this use case as it’ll be less actions, making it simpler.

I need to actually open the builder to troubleshoot further - could you please share your automation?


here is the version with regex: Shared Playbook Template

Thank you - Here’s the updated playbook with the things you were missing:

A few things you were missing:

  • Your regex is working as expected
  1. We needed to add another action after the Regular Expression actions to put all the information into a table. Use “Get table sorted by”

  2. Because of this added step, we also needed to update your mapping in the “Add data to Airtable” action:

  • These mappings need to come from the “Get table sorted by” previous action.
  • Please double check these on your end as it was a lot and I might’ve missed some.

I hope this helps!
Thank you,

1 Like

thank you for your effort!

Two things I have now: the problem with the numbers. I get still only the two digits 99 and not the whole number (price) 99841 in Airtable.

And the other thing is, that my scraping flow creates now two rows with the same data in my airtable.

I’m thinking we might’ve uncovered a couple of bugs here, but tagging @vin_bardeen, @ivan to take a second look as I’m not super familiar with Airtable. Thank you!

FWIW - I’m encountering the same behavior on my end of testing that @LastSamuraj mentions:

Hello @vin_bardeen,

could you please take a look on my problem?
I’m still not able to scrape a simple euro amount into an airtable digit field. As I already told above, every time I scrape e.g. this amount 90.900 €, I only get the 90 as digit in my airtable field.

I think maybe the problem is the dot inside the amount. For this reason, I tried to remove the dot using a regex. But no matter which RegEx formula I tried, it didn’t work. Each time only the number 90 was transferred to Airtable.

What is the best way to solve this problem?

@vin_bardeen, Could you please confirm this has been escalated to the engineers?

I think it’s the same issue here possibly - Cannot Scrape Numbers to use for an Airtable number-formatted column + "get function of" errors

Hey Jess, no I didn‘t get an respons to my problem.

I see that, that’s why I’ve followed up with Vin again above :+1:

Hi @LastSamuraj and @Jess ,

Thanks for following up on this and for your patience while we resolved this issue. We’ve just released a new version of Bardeen (2.39.0) which is meant to have fixed this issue. Do you mind updating to the latest version and seeing if it persists for you please ?

Hello @vin_bardeen , after bardeen update to 2.39.0 the transfer of fields that are not unique no longer works. This means that all fields that worked yesterday (e.g. 300 HP, 500 km, 180 km/h etc.) are no longer transferred. And the price is not transferred either.

I get the following success message after running my workflow.

Here is an example of the fields I am copying:

Previously, Bardeen always said: “You are trying to use a different kind of data than the current argument expects. Bardeen will convert it, but the result may be unexpected.”

Apparently it doesn’t work anymore since the update

Thanks for the update @LastSamuraj

Tagging @bagrat to see if he has any ideas.