First row empty and cutting off AI answers

I have a playbook that is not performing as expected.

  1. The first row in Google Sheets that is created is always completely empty. Is this a familiar error?
  2. I run “get answer based on a question” AI. The answer is always cut off. It seems to be around 984 characters. Is there a max length to this answer? Am I doing something else wrong?

Here is the automation:

Hi @Bob,

It appears you’re using two “scrape data on active tab” actions. This is likely what’s happening here - It won’t work well as it’s referring to the web browser tab that you currently have selected so it will only scrape from that link.

I suggest using the “Scrape data in the background” as your second action instead.

I hope this helps!
Thank you,

1 Like

Thanks. I’ll give this a try. Don’t think i would have worked this out myself.

Yes, it worked @Jess :tada:

1 Like

We love to hear it! Thank you for the update! :smiling_face:

1 Like

Hi Jess,
So the cutting off answers has been solved. But the first row of every scrape is always empty. Do you know whats going on here?

IS there something Im doing wrong?

I can easily add a condition and filter out the empty lines, but good to know if im doing something wrong here.

Hi @Bob ,

Does the empty row issue still take place? I am trying to reproduce it by running a copy of your playbook on a copy of your google sheet and the rows seem to be added without empty lines.

I can possibly help you debug it, but I’d need some more information about this. Do you run the playbook with the same settings when getting empty rows? Your playbook looks good, the only place I’d question is the duplicated input for the AI prompt:

In general empty rows is not something that should occur.

Hey Victoria, thanks for the response and having a look! yes its still adding empty lines.

I run the playbook with the same settings every time and always get the sae empty rows? i had this with other versions of scraping this website too, so perhaps it has something to do with the website. Im not running into this issue with other website scraper to date. Let me know if you are able to figure it out, i wasnt.

It looks like duplicated input, but it is not. This is referring to two different scrape actions (one on teh list page and one on the details page).

thanks for all the help, appreciate it. Getting better at it by the minute.

1 Like

Hi @Bob,

Here’s your scraper template in the first action.

It appears that the first row is blank because the first row is blank here. We probably need to update your container on the scraper to grab only the values you’re looking for. Let me trial/error on my end here, and I’ll give you an update.

Thank you,

Here you are @Bob

Update the container in the scraper with the following:

#agenda-listing > ul > li > a

This should fix your empty rows issue.

Thank you,

Thank you Jess! Will give this a try!

1 Like

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.